Home Ask a Librarian Site Search

Need a Plug-in?

Many web pages need to have plug-ins installed before the page will display properly. The following plug-in programs are installed on the library computers. Use the links provided to download the plug-ins to your computer.

The library installs and uses the latest version unless otherwise noted.

Plug-in/Program

  1. Apple QuickTime
  2. Adobe Flash Player
  3. Adobe Shockwave Player
  4. Adobe Acrobat Reader
  5. Ebrary
    1. Need for Blackwell e-books
      1. Installs normally into IExplorer
      2. Workaround required for FireFox 3
  6. EndNote Web (free user account required)
  7. Java
  8. MS Silverlight
  9. RealPlayer
  10. Windows Media Player Firefox Plugin
  11. Zotero (Chrome, Firefox and Safari)
Last Modified 10/10/2014 kk